꿈을꾸는 파랑새

반응형

모질라에서 제공을 하고 있는 브라우저인 파이어폭스(Firefox)에 대한 보안 업데이트 및 버그 수정 업데이트가 202년 2월 6일에 업데이트가 진행이 되었습니다.
독립 실행 형 다운로드는 Mozilla 웹 사이트에서 제공되는 것을 설치를 하시면 되고 기본적으로 메뉴-> 도움말-> Firefox 정보를 선택하여 현재 설치된 브라우저 버전을 확인을 하고 업데이트를 진행을 할 수가 있습니다.
Firefox 85.0.1 및 Firefox ESR 78.7.1은 가장 중요한 보안 업데이트이며 Mozilla는 두 버전의 브라우저에서 단일 보안 문제를 패치를 진행을 했습니다.
해당 취약점은 압축된 텍스처에 대한 깊이 피치 계산에 버퍼 오버 플로우가 발생을 하는 문제입니다. 해당 문제는 Windows 시스템에서 실행되는 Firefox에만 영향을 미치며 지원되는 다른 모든 운영 체제는 이 문제의 영향을 받지 않는다고 했습니다.
MOZ-2021-0001: Buffer overflow in depth pitch calculations for compressed textures
Description:In the Angle graphics library, depth pitch computations did not take into account the block size and simply multiplied the row pitch with the pixel height. This caused the load functions to use a very high depth pitch, reading past the end of the user-supplied buffer.
Note: This issue only affected Windows operating systems. Other operating systems are unaffected.
This issue has been assigned a temporary identifier, pending assignment of a CVE.
Firefox 85.0.1은 그 옆에 있는 브라우저에서 5 개의 비보안 관련 버그를 수정합니다.

파이어폭스 85.0.1 중요한 보안 업데이트 및 버그 수정

먼저 두 가지 브라우저 충돌 문제를 해결했습니다. 첫 번째는 Apple Silicon CPU가 장착된 macOS 장치에서 SPNEGO를 사용하여 웹 사이트에 인증할 때 와 두 번째는 예기치 않은 캐시 API 상태의 경우입니다.
Firefox 85의 Flatpack에서 Flatpack 또는 rpm Zoom 클라이언트를 실행하려는 Linux 사용자는 더 이상 실행할 수 없다는 사실을 새 릴리스의 세 번째 수정은 Firefox Flatpack을 사용할 때 외부 URL 스키마 핸들러를 수정하여 해당 문제를 해결합니다.
Mozilla 엔지니어는 브라우저를 사용할 때 NTFS 특수 경로에 대한 액세스를 방지하는 Firefox 85.0.1의 변경 사항을 구현했으며 Mozilla는 액세스가 파일 시스템 손상을 초래할 수 있다고 지적했습니다.
최종 수정은 Firefox가 특정 문서 끝에 추가 용지를 인쇄하지 못하도록 하며 Bugzilla @ Mozilla의 layout.display-list.improve-fragmentation 설정을 활성화로 설정하여 PDF 문서를 인쇄할 때 문제를 발생을 했다고 합니다.
파이어폭스 브라우저를 사용을 하고 계시는 분들 해당 보안 업데이트를 진행을 통해 안전하게 인터넷을 사용을 하시면 될 것입니다.

반응형

공유하기

facebook twitter kakaoTalk kakaostory naver band

댓글

비밀글모드

  1. 보안 업데이트는 필수겠지요
    잘 보고 갑니다.. ^^
    2021.02.08 08:50 신고
    • 네~ 보안 업데이트는 필수라고 생각을 합니다.
      2021.02.10 02:08 신고